Hlavní navigace

V čipech Kaby Lake a Skylake objevena kritická chyba hyper-threadingu

Sdílet

Pavel Kreuziger 26. 6. 2017

Tento problém, který dokáže destabilizovat čipy a vést k nepředvídatelnému chování systému, porušení dat a k jejich ztrátě byl popsán v e-mailu rozeslaném uživatelům Debianu. Týká se procesorů Intel Core generací Skylake i Kaby Lake (na desktopech, high-endových desktopech, embedded a mobilních platformách, serverových procesorů Xeon v5 a v6 a některých modelů řady Pentium. A protože je Debian distribucí Linuxu, může se problém objevit na jakémkoliv operačním systému.

Problém je popisován takto: „Za komplexních mikro-architekturních podmínek mohou krátké smyčky méně než 64 instrukcí využívajících registry AH, BH, CH nebo DH, jakož i jejich odpovídající širší registr (například RAX, EAX nebo AX pro AH) mohou způsobovat nepředvídatelné chování systému. K tomu může dojít jen tehdy, když jsou aktivní oba logické procesory na stejném procesoru fyzickém.“

Je třeba zmínit, že většina uživatelů se s přesnými podmínkami replikace, které nejsou jasně specifikovány, nejspíše nesetká. Debian.org přesto stále doporučuje deaktivaci hyper-treadingu do doby, než bude aplikován update mikrokódu. Intel sice údajně nějaké záplaty vydal, ty však musejí být integrovány do aktualizací BIOSu/UEFI základní desky.

Zdroj: Techspot.com

Našli jste v článku chybu?